View Full Version : List of bugs

January 2nd, 2018, 10:48 AM

I'm Essie in-game and I'll be posting all the bugs I could think of I came across in-game.

First off the famous Dungeon Historical Ranking rewards in the mailbox.
You actually get these items immediately when you finished the dungeon.
But for some reason you still get a mail where you'd supposedly get the items, and it creates some kind of error.

Second, yesterday we were out with the guild killing stuff.
We did the Kill 80 Elites Daily Event and also the Wilderness Boss, but killing the boss did not finish the quest for killing a Wilderness Boss.

Also, when we tribute summoned Nuclei, nothing happened when we were inside. (Note: I summoned it but was not party leader, maybe that caused a bug? We're not sure right now and don't want to waste more Nuclei Stones until we know what's going on)

Then a small bug in Monster Factory, Talent Chance gets messed up.

Not sure if these are bugs either:

The blue area on the map was literally blue for a few minutes when entering the wilderness for the first time for me, not sure why it happened.

At lvl 35 we can apparently finally enter our "Castle", but nobody knows how the hell we do it, lol.

Also, there's a quest for clearing an Arcane level dungeon with a guild member, but we have no idea how to do an "Arcane" dungeon, is it like harder than Hard mode and like lvl 40+ or something? We don't know. We have tried a lot of things but nothing worked.

Found a quest bug:

Quest tells you to speak with "Senior Hunter Matthew", but you actually have to talk with "Slim Jim". He was luckely near Matthew, so I noticed what was wrong.

Another bug in dungeon, I died, my guild member finished killing the boss. I respawned as normal because the dungeon finished, but then I suddenly die immediately after I respawn. Luckely I did the Dungeon without Fatigue, otherwise I probably wouldn't have been able to get my chest. I suppose I died from AoE damage from boss after I died. Normally I had this happen before too in another dungeon. These buggy deaths haven't happened repeatedly though, so probably not very common that this occurs.


About the Arcane Dungeon, today we found out it is a lvl 40+ Daily Event on Thursday.


Same with "World Boss" quest. We suppose it's another kind of Boss, the one that spawns 7 days after server opening.


Daily Mission Quest Bug, says to collect "Leather Belt", but it's called "Leather Cap".


Training Project Quest from "Odin" apparently not working for other players (it's level 38 quest and I'm lvl 37 so haven't been able to try this out myself). Apparently they run and dodge as they were told but it does not complete the quest for them.

Amun-Ra Quest & Great Dam Quest bug, it says you have to clear the Hard mode of those dungeons, but instead you have to clear Anubis Hard mode.


Trying to buy a "Mysterious Object" at the black market gives an error.


Update on the Odin Quest Bug "Dodge and Run"... I received the quest, but I have to talk to Odin again but it doesn't do anything.
The Dodge and Run training wasn't bugged for me, just really really hard. But I completed it after a few tries.


Thanks for reading and I hope this information is useful ~~~

P.S. This game is so great. I'm sad to see the big backlash on Steam because everyone thinks it is going to be heavy pay2win. Right now it's slightly pay2win but it's not a big deal. I've played some REAL pay2win games before and that was a big difference. I hear from a lot of people they won't come back after Closed Beta if Fatigue is not fixed/removed etc. Idk what you guys will do about it. For me it didn't bother me until I got a higher level, because dungeons keep needing more and more Fatigue. You can literally do 3 dungeons and run out of fatigue already. Just unfortunate a lot of people probably just didn't bother trying to play this game because of all the negativity on Steam.

And talking about dungeons and fatigue I remembered a bug.
When you have like 20 fatigue or something, you can still enter a dungeon that needs more fatigue than you have as long as you have atleast 1 fatigue, and you still get all the rewards from the dungeon.

And I don't know why the [Spoiler]'s screw up my post so much, but atleast it's better than gigantic pictures. :P

January 2nd, 2018, 04:18 PM
Nice bug list Essie, keep it up

January 2nd, 2018, 07:40 PM
Gonna sticky this up.

I may be no expert on the game, but if you find more bugs that you'd like me to put on the list (since your edit time should have expired by now), let me know and explain in detail!

January 4th, 2018, 05:16 PM
Thank you SO much for listing all these bugs. It will be a huge help in shoring up these issues.

Also, personally our GM Team would LOVE to eliminate the Fatigue system. Our fingers are crossed in hopes that the developer would remove this system. We hope to have an update on this soon.

January 6th, 2018, 06:23 AM
When in the "safe" waiting area before starting a dungeon, you can use your skills to get relic energy, tho there are no enemies. Creates an unfair advantage causing you to potentially start with a relic buff and/or a full energy bar.


January 6th, 2018, 07:33 AM
A thief spawned in wilderness, but I had 0 fatigue so couldn't pick up the coins, but you can't use fatigue potions in wilderness either >.> So would be nice if you could enable using fatigue potions in the wilderness.


Also, please remove the "knock down" or whatever effect from guns/bullets, it's SO overpowered. You can litterally stand still and shoot something and it can't even move. Same with PvP, if a player attacks you with a gun, you're litterally just stuck and can't attack back unless you dodge or the other player runs out of ammo. Lower range guns doing more damage is OK but this knock-down or something effect is just broken in both PvE and PvP. Or make it slow others or something, like bullets apply 10% slow and arrows 20%, for like (half) a second. Would be really nice.

January 6th, 2018, 09:33 AM
At dungeon, 9 Lost Palace of Anubis on normal mode, it consumes 34 fatigue not 24 as it says.

January 6th, 2018, 03:58 PM
I think there is something wrong with the wilderness boss gear drops, and maybe in other places too like the dungeons. All we ever get is bracers, gloves or watches. Sometimes maybe GPS or something. Same with dungeon I think at higher levels/higher quality gear. It's very strange. Or maybe it's just a coincidence. Just wanted to share my concern about this.

The amount of Skill Scrolls you get to lock the skill on your gear is actually very low compared to the skill scroll lock remover scrolls. And upon that there are loads of different Skill Scrolls as only Skill scroll only applies on 3 different types of equipment, and I've even seen a purple and yellow one for the same equipment and I don't even know what the difference would be. Yellow for yellow equipment then only? Still a too many and too rare. would be better if it were just one skill scroll for purple gear and one for yellow gear.

The invinsibility on the 'Cloaking Sphere' skill doesn't work in Monster Factory and with Wilderness bosses. You are still being aggro'd for some reason.


Also, I noticed my 'Energize' skill sometimes bugs when activated right before being knocked down, it won't activate the spell, but put it on cooldown.


When an occupied obelisk in the wilderness is leveling up from level 2 to 3, it says it's leveling up to level 6 instead of 3. Also the time is wrong when it says "leveling up in 43:50" or something. Atleast for level 1 to 2 it was, as it said it would level up in 40-45min, but it leveled up in 5-10min already.

Castle bug update: at level 40 it said you could enter it, but we didn't know how. But the mystery has been solved, you actually can't enter it until lvl 45, instead of lvl 40.

Also, 'update' on the Odin quest bug (quest wasn't working, talking to Odin wouldn't give the quest to do Training) was fixed the next day after I reported it here on the forum. But for someone else then it wasn't apparently, so very strange.

January 7th, 2018, 10:47 AM
Some Relics are bugged. With that what I mean is that you can't drag some Relics to your Relic Slots. (For example: Templar Badge & Battle Horn).

January 7th, 2018, 12:56 PM
How to pick up the items on the pillar?