PDA

View Full Version : I need help gm !



Jorgeino
January 4th, 2011, 12:17 PM
Please Gms, today is January 4 and would get a 3x event, and updated my patch and I cannot log in, looks like this: version does not match
Please ask your help because I will soon travel six days and I will lose my remaining time of event, Thank you Dooc !:eek:

Saccharide
January 4th, 2011, 03:06 PM
Can you post a screen shot?