View Full Version : d3dx9_43.dll error. I REALLY need help PLEASE

September 16th, 2014, 05:43 AM
I just re-installed the game years after quitting and I get this error: Cannot find 'd3dx9_43.dll'. Please, re-install this application. I just fresh download and installed it ad even downloaded the manual patch, I don't know what to do. (Windows 7, latest update.)
I have tried downloading and installing Microsoft direct x but it says i have the latest update.
I have uninstalled and re-installed the game from the site and full clients from the forums (This one: https://forum.subagames.com/showthread.php?t=70445 )
I googled it and everything and no luck. Someone please help.
P.S. I am also trying to install it on a windows 8 computer and get the same issue.

September 16th, 2014, 08:57 AM
There is not really something I can do right now, but i'll let you know when we find anything that can help you with this problem.
Cidopuck knows about this as well.

September 16th, 2014, 10:12 AM
have you tried with this directx? Download DirectX End-User Runtimes (June 2010) from Official Microsoft Download Center (http://www.microsoft.com/en-us/download/details.aspx?id=8109) umm you can try to run the game in windows xp compatibility mode.

September 16th, 2014, 11:03 AM
install directx or update it. u havent this very file "d3dx9_43.dll", its a library file of directx. u can easily find it in the internet and download, then replace into Divine Souls folder.

one more: u can try to download directx (the latest version - if im not mistaken its 11 version) and install it manualy.

September 16th, 2014, 06:44 PM
I dont know where to insstall it at. :confused:

September 16th, 2014, 06:45 PM
I dont know where to insstall it at. :confused: @UprisingBldD5j5

September 16th, 2014, 06:47 PM
@ Ela1ra I have downloaded and installed it manually and still no luck. Without a link to download the missing file I dont dare google it and download a bad virus. :(

September 17th, 2014, 09:04 AM
write me ur email, ill send u this file

September 18th, 2014, 09:43 PM
I messaged it to you @ Ela1ra