Results 1 to 5 of 5

Thread: RTD Quest got stuck

  1. #1

    Default RTD Quest got stuck

    Hello, i cant do my 2nd role due to the bug that occured in my RTD Quest.
    Its the quest "Many difficulties." from Beggar Hybrid.(Ch2 Q 16)
    I have to Kill "Red Eyes ...." but if i kill him the quest doesnt count it.
    I tried around 30 times.
    ID avdalim2

  2. #2


    You don't kill him. Take of your weapon and hit him until he follows you and until you get a quest update.

  3. #3


    When you hit him, it wont say anything in red text, just check your map it will show back in village a yellow ! Yeh you have to use a physical attack not a nuke. Use your fist and just swipe him, you dont even need to kill him, just touch him and run back to village.

  4. #4


    Kay ty guys

  5. #5


    If you could let me know when you have fixed the issue, I'll close this thread and change the title to [solved].

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts