Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: MAT Legacy Loading Screen Problems

  1. #1
    Join Date
    Mar 2012

    Default MAT Legacy Loading Screen Problems

    Here is a solution that has worked for several users when their loading screen was stuck on their desktop.

    Win 7:

    Win 8:

    Remove any unnecessary programs that eat up your computer's RAM. Programs under "c:/windows" or "microsoft corporation" should be left with the checkmark "on", as they are needed to run your computer. You can remove some of them if you know what you're doing.

    It appears this problem is related to RAM, Nvidia cards may also cause this issue for some users in which case you'd turn off your nvidia card in the same window shown in those videos.

    Thanks to Ivan and Petrovs for their good work!

    GM Tranzor

  2. #2


    This is the correct link for windows 8

  3. #3


    It still doesn't work for me.

  4. #4


    It works for me yeaaaa

  5. #5


    No funciona otra forma de arreglarlo por favor pero con windows 10
    por favor!!!

  6. #6


    Quote Originally Posted by DANILK View Post
    No funciona otra forma de arreglarlo por favor pero con windows 10
    por favor!!!
    Please use English language in English section.

    Have you tried running MAT with compatibility for Windows8/7 ?
    Also you might want to run MAT with Integrated Graphic instead of Nvidia graphic.
    IGN (MAT) : Toffy - Moderator

  7. #7


    Nope did nothing, Im even running Advanced System Care's Game Booster and still nothing just continuously loads, continuously loading everywhere. Running Windows 8.1 laptops up to date.
    Last edited by BLUEJUSTICE; August 27th, 2015 at 12:48 AM. Reason: Software Specs

  8. #8


    i tried these ones and it doesnt work new one please?
    at the picature its freezing
    Thanks for the help.

  9. #9


    ugh, aaand i was hoping to play this game again after not playing for a few year but am being shafted because of no details on fixes that work.

  10. #10


    cmd -> "msedit" -> "hide windows services" -> "disable all"
    cmd -> "msedit" -> "startup" -> "Go to Task Manager" -> "Startup" -> Disable as needed

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts